愛查股網 www.islmmw.live 股票查詢最好股票網 個股數據查詢好股網 手機訪問本頁
| 保存本站網址 | 關閉站內廣告
愛查股網
股票查詢最好股票網 個股數據查詢好股網
您的位置:愛查股網 > 股票公式 > 通達信公式
股票公式搜索:

通達信MACD+KDJ+RSI主圖指標公式

DE:=CONST(LLV(L,90));
JI:=CONST(HHV(H,90))-DE;
DE_K:=DE+JI/3*2;
JI_K:=JI/2;
L_00:=DE_K;
L_20:=JI_K/5+DE_K;
L_80:=JI_K*4/5+DE_K;
L_100:=JI_K+DE_K;
L_5:=L_100-L_00;
L_50:=(L_00+L_100)/2;
DRAWBAND(L_100,RGB(00,180,00),L_00,DRAWNULL);
DRAWBAND(L_80,RGB(00,150,00),L_00,DRAWNULL);
DRAWBAND(L_50,RGB(00,100,00),L_00,DRAWNULL);
DRAWBAND(L_20,RGB(00,55,00),L_00,DRAWNULL);
DRAWTEXT(CURRBARSCOUNT=200/2,L_100-(L_100*0.03),'====【傳統指標MACD、KDJ、RSI.編制】===='),COLORWHITE;
DRAWTEXT(ISLASTBAR,L_100,'100'),COLORRED;
DRAWTEXT(ISLASTBAR,L_80,' 80'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,L_50,' 50'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,L_20,' 20'),COLOR00FF00;
DRAWTEXT(ISLASTBAR,L_00,'0'),COLORWHITE;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
DRAWBAND((RSI1/100-0.5)*L_5/1+L_50,RGB(255,50,50),(RSI2/100-0.5)*L_5/1+L_50,RGB(00,180,80));
DRAWICON(CROSS(80,RSI1),L_100,15);
DRAWICON(CROSS(RSI1,20),L_00,23);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
DE_A:=CONST(LLV(RSV,90));
DD_A:=CONST(HHV(RSV,90))-DE_A;
R:=(RSV-DE_A)/DD_A;
RSV1:=R*JI_K+DE_K;
K:SMA(RSV1,3,1),COLORFFFFFF;
D:SMA(K,3,1),COLORYELLOW;
J:3*K-2*D,COLORFF00FF;
DE_M:DE+JI/3,COLORRED;
JI_M:=JI/2;
KDL:=CONST(LLV(EMA(C,26),90));
KDH:=CONST(HHV(EMA(C,26),90))-KDL;
R_K1:=(EMA(C,12)-KDL)/KDH;
R_K2:=(EMA(C,26)-KDL)/KDH;
DIF:(R_K1-R_K2)*JI*1.5+DE_M,COLOR00FF00;
DEA:EMA(DIF,9),COLORLIBLUE;
MACD:=(DIF-DEA)*2+DE_M;
STICKLINE(MACD<REF(MACD,1)AND MACD>DE_M AND CROSS(K,J),DE_M,MACD,2.8,0),COLORFF3300;
STICKLINE(MACD>REF(MACD,1)AND MACD<DE_M AND CROSS(J,K),DE_M,MACD,2.8,0),COLORRED;
STICKLINE(MACD<DEA AND MACD>DE_M AND CROSS(D,K),DE_M,MACD,2.8,0),COLOR00FF00;
DRAWKLINE(H,O,L,C);
STICKLINE(MACD>=DE_M,MACD,DE_M,0,0),COLORRED;
D_1:=MACD>H AND H>=DE_M AND DE_M>=L;
D_2:=MACD>H AND H>=L AND L>DE_M;
D_3:=H>MACD AND MACD>=L AND L>DE_M;
D_4:=H>MACD AND MACD>DE_M AND DE_M>=L;
STICKLINE(D_1>0,H,DE_M,0,0),COLORYELLOW;
STICKLINE(D_2,H,L,0,0),COLORYELLOW;
STICKLINE(D_3,MACD,L,0,0),COLORYELLOW;
STICKLINE(D_4,MACD,DE_M,0,0),COLORYELLOW;
D_5:=MACD<L AND L<=DE_M AND DE_M<=H;
D_6:=MACD<L AND H<DE_M;
D_7:=L<MACD AND MACD<=H AND H<DE_M;
D_8:=L<MACD AND MACD<DE_M AND DE_M<=H;
{www.islmmw.live 愛查股公式網_最新股票指標公式}
STICKLINE(MACD<DE_M,DE_M,MACD,0,0),COLOR009900;{LIBLUE}
STICKLINE(D_5,DE_M,L,0,0),COLORYELLOW;
STICKLINE(D_6,H,L,0,0),COLORYELLOW;
STICKLINE(D_7,H,MACD,0,0),COLORYELLOW;
STICKLINE(D_8,DE_M,MACD,0,0),COLORYELLOW;
DRAWTEXT(ISLASTBAR,DE_M,'零軸線'),COLORWHITE;
DRAWBAND(MA(DIF,2),RGB(255,255,255),DIF,RGB(455,0,455));
DEA,COLORYELLOW;
{BS主圖}
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
賣:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0);
DRAWICON(FILTER(賣=1,1),HIGH*1.01,8);
買入:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLOR0000FF;
MA1:=SMA(C,3,1),COLORGREEN;
DRAWICON(CROSS(MA1,買入),L*0.99,7);

股票公式推薦
在線查股
商務合作:在線客服
愛查股網不推薦股票,不收會員,網站內的廣告不代表本股票網的觀點,由此引起的一切法律責任均與本站無關,股市有風險,投資需謹慎。粵ICP備17111814號-1
特別提示:本站不為所提供數據的錯誤、殘缺、延遲或因依靠此信息所采取的任何行為負責。本股票網提供的所有內容僅供參考,不構成投資建議,投資者據此操作,風險自擔。
手機版(手機訪問當前頁面) | 電腦端(適合電腦或大屏用戶)
小丑扑克1手走势图 赚钱宝已占空间0kb 金花三张牌规则 极速时时彩预测 爱波网足球指数 免费麻将游戏4人打麻将 新疆时时彩网站 手机天天棋牌游戏大厅 6000w彩票平台正规吗 玩手游赚钱论坛 快乐飞艇全天计划 宁夏十一选五 北京快3开奖结果今天 极速十一选五技巧 搜狐足球指数 星露谷物语 初期最快赚钱 幸运飞艇