愛查股網 www.islmmw.live 股票查詢最好股票網 個股數據查詢好股網 手機訪問本頁
| 保存本站網址 | 關閉站內廣告
愛查股網
股票查詢最好股票網 個股數據查詢好股網
您的位置:愛查股網 > 股票公式 > 飛狐公式
股票公式搜索:

飛狐量化RSI指標公式

input:n1(14),n(3);
LC := REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
ty:=rsi1;
A1:=REF(ty,N)=HHV(ty,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); D1:=FILTER(C1,N);{高}
A2:=REF(ty,N)=LLV(ty,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); D2:=FILTER(C2,N);{低}
H1:=(D1 AND NOT(D2)) OR BARSTATUS=2 OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1));H2:=D1 AND NOT(D2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{過濾后低點}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{過濾后高點}
R1:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1); S1:=R1>REF(R1,1); {前一高}
T1:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1); U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1); {前三低}
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); U4:=T4>REF(T4,1); {前四低}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1); {前三高}
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); S4:=R4>REF(R4,1); {前四高}
壓一:DRAWLINE(S2,ty,S1,ty,1),Color80FFFF; {★壓力1:}
撐一:DRAWLINE(U2,ty,U1,ty,1),POINTDOT,Color00FFFF,linethick2;{★支撐1:}
壓二:DRAWLINE(S3,ty,S2,ty,1),ColorFF8000; {★壓力2:}
撐二:DRAWLINE(U3,ty,U2,ty,1),POINTDOT,ColorFF8000;{★支撐2:}
壓三:DRAWLINE(S4,ty,S3,ty,1),Color0000FF;{★壓力3:}
撐三:DRAWLINE(U4,ty,U3,ty,1),POINTDOT,Color0000FF;{★支撐3:};
QS:=HHV(RSI1,13);
RS:=llV(RSI1,13);
Var1:=BACKSET(REF(QS,2)=HHV(QS,5),3);
Var2:=CROSS(Var1,0.9);
Var3:=BACKSET(REF(RS,2)=LLV(RS,5),3);
Var4:=CROSS(Var3,0.9);
壓力:REF(QS,BARSLAST(Var2)),POINTDOT,Color00ff00;
STICKLINE(RSI1,REF(QS,BARSLAST(Var2)),REF(QS,BARSLAST(Var2)),5,0),Color00ff00;
支撐:REF(RS,BARSLAST(Var4)),POINTDOT,Color0087FF;
STICKLINE(RSI1,REF(RS,BARSLAST(Var4)),REF(RS,BARSLAST(Var4)),5,0),Color0087FF;

股票公式推薦
在線查股
商務合作:在線客服
愛查股網不推薦股票,不收會員,網站內的廣告不代表本股票網的觀點,由此引起的一切法律責任均與本站無關,股市有風險,投資需謹慎。粵ICP備17111814號-1
特別提示:本站不為所提供數據的錯誤、殘缺、延遲或因依靠此信息所采取的任何行為負責。本股票網提供的所有內容僅供參考,不構成投資建議,投資者據此操作,風險自擔。
手機版(手機訪問當前頁面) | 電腦端(適合電腦或大屏用戶)
小丑扑克1手走势图 内蒙古快三开奖号码 新疆35选7历史开奖号码 斗牛牛官方下载 1期曾道人提供 去澳大利亚打工赚钱吗. nba文字比分直播 浙江20选5综合走势图 3d奇偶分布图 极速快3开奖历史 海南飞鱼开奖号码查询 现金棋牌下载app送18 极速时时彩 牙科耗材赚钱吗 l排列五走势图带连线 竞彩比分攻略 加盟股票配资