愛查股網 www.islmmw.live 股票查詢最好股票網 個股數據查詢好股網 手機訪問本頁
| 保存本站網址 | 關閉站內廣告
愛查股網
股票查詢最好股票網 個股數據查詢好股網
您的位置:愛查股網 > 股票公式 > 通達信公式
股票行情查詢:

通達信幺三五主圖指標公式

2019/7/1 21:23:46

EMA13:MA(C,13),COLORWHITE;
EMA34:MA(C,34),COLORYELLOW;
EMA55:MA(C,55),COLORFF00FF;
天線:MA(REF(HHV(C,30),1),2),COLORLIBLUE;
地線:MA(REF(LLV(C,30),1),2),COLORLIBLUE;
{彩色漲停板}
A:=C-O;
B:=C/REF(C,1)>=1.093 AND H=C;
STICKLINE(B,O,O+A/4,3,0),COLORFF99FF;
STICKLINE(B,O+A/4,O+A*2/4,3,0),COLORFF00FF;
STICKLINE(B,O+A*2/4,O+A*3/4,3,0),COLOR9900FF;
STICKLINE(B,O+A*3/4,O+A,3,0),COLOR0000FF;
{見好就收}
Y:=(EMA13-EMA55)/EMA13*100;
JHJX:=REF(Y,1)<=10 AND Y>10;
{DRAWICON(JHJX,H,1);}
DRAWTEXT(JHJX,H+0.03,'見好'),COLOR00FF99;
{紅杏出墻}
HX1:=EMA34>EMA13 AND EMA55>EMA34;{股價長期下跌,并且遠離長期均線}
HX2:=BARSLAST((C-EMA13)/EMA13*100<-6);{收盤價在13均線%6到現在的天數}
HX3:=ABS(1-EMA55/REF(C,1))>0.1;
HX6:=BARSLAST(CROSS(EMA55,EMA34))>=20;{13日均線下降趨于走平}
HX4:=ABS(1-REF(EMA13,1)/EMA13)<0.004 AND EMA34>C;
HX5:=EMA13>REF(C,1) AND C>EMA13 AND C>O;
HX7:=HX1 {AND HX3} AND HX4 AND HX5 ;
HX8:=HX7 AND FILTER(HX7,10);{滿足后10天內不標記}
DRAWTEXT(HX8,H,'紅杏'),COLORYELLOW;
{螞蟻上樹}
BR1:=COUNT(BETWEEN(((C-O)/O)*100,0,5) ,5)=5;{5日內收盤價都比前日收盤價高}
BR2:=(ABS(EMA13-EMA34)+ABS(EMA34-EMA55))/C<0.1;{主均線相距很近或基本持平}
BR3:=C>EMA55 AND COUNT(EMA55>L,5)>=1;{股價送上55日均線}
MYSS:=BR1 AND BR2 AND BR3;
DRAWTEXT(MYSS AND FILTER(MYSS,5),H,'螞蟻'),COLOR00C5FF;
{黑客點擊}
DJ1:=EMA13>EMA34 AND EMA55>EMA34;{13日均線大于34日均線,34日均線小于55日均線}
DJ2:=O>EMA55;{開盤價大于55日均線}
DJ3:=CROSS(EMA13,EMA55) OR ABS(1-EMA13/EMA55)<0.002;
DJ4:=O>C AND REF(C,1)>C;
HKDJ:= DJ2 AND DJ3 AND DJ4;
DRAWTEXT(HKDJ AND FILTER(HKDJ,10),L-0.03,'黑客'),COLORD6BA63;
{紅衣俠女}
XN1:=ABS(1-HHV(EMA55,5)/LLV(EMA55,5))<0.02;
XN2:=CROSS(EMA13,EMA55) OR ABS(1-EMA13/EMA55)<0.002;
XN3:=C>O AND V>REF(V,1) AND C>EMA55;
HYXN:=XN1 AND XN2 AND XN3;
DRAWTEXT(HYXN AND FILTER(HYXN,5),L-0.05,'紅衣'),COLOR00FF99;
{海底撈月}
LY1:=COUNT(ABS(1-EMA55/EMA34)<0.1,20)>=16;
LY2:=COUNT(CROSS(EMA34,EMA13),40)>=1 AND COUNT(CROSS(EMA55,EMA13),40)>=1;
LY3:=CROSS(EMA13,EMA55);
HDLY:=LY1 AND LY2 AND LY3;
DRAWTEXT(HDLY AND FILTER(HDLY,5),L-0.25,'撈月'),COLORGREEN;
{均線互換}
JXHH:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55);
DRAWTEXT(JXHH,L+0.09,'線換'),COLOR0099FF;
{梅開二度}
MKED1:=BARSLAST(REF(CROSS(EMA34,EMA13),1));
MKED2:=COUNT(H>=EMA55,MKED1)=MKED1;
MKED:=MKED2 AND CROSS(EMA13,EMA34);
DRAWTEXT(MKED,H+0.02,'梅二'),COLOR0044FF;
{一陽三線}
YY1:=C>EMA13 AND EMA13>O;
YY2:=C>EMA34 AND EMA34>O;
YY3:=C>EMA55 AND EMA55>O;
YYSX:=YY1 AND YY2 AND YY3;
DRAWTEXT(YYSX,H+0.1,'陽三'),COLORRED;
{揭竿而起}
MAX3:=MAX(MAX(EMA13,EMA34),EMA55);
MIN3:=MIN(MIN(EMA13,EMA34),EMA55);
JG1:=C*0.05>ABS(EMA13-EMA34);{13線34線55線接近}
JG2:=C*0.05>ABS(EMA34-EMA55);
JG3:=C>=O*1.03 AND C>MAX3;{陽線3%}
JG4:=O>MIN3 AND MAX3>O;
JG5:=C>REF(H,5);
JG6:=(C-EMA34)/EMA34<=0.15;{控制價高}
JG7:=V>MA(V,5) AND MA(V,10);
JGEQ:=JG1 AND JG2 AND JG3 AND JG4 AND JG5 AND JG6 AND JG7;
DRAWTEXT(JGEQ,H+0.1,'揭竿'),COLORGREEN;
{三線推進}
MAX4:=MAX(MAX(MAX(EMA13,EMA34),EMA55),H);
MIN4:=MIN(MIN(MIN(EMA13,EMA34),EMA55),L);
SXTJ1:=HHV(MAX4,60);
SXTJ2:=LLV(MIN4,60);
SXTJ3:=EVERY(ABS(1-SXTJ1/SXTJ2)<0.3,20);
SXTJ:=SXTJ3 AND (YYSX OR JGEQ);
DRAWTEXT(SXTJ AND FILTER(SXTJ,10),H+0.25,'三線推進'),COLOR00C5FF;
{浪子回頭}
LZ1:=REF(O,2)>REF(C,2) AND REF(O,1)>REF(C,1) AND O>C;
LZ2:=C<=REF(C,1) AND REF(C,1)<=REF(C,2);
LZ3:=REF(V,3)>MA(V,3);
LZ4:=REF(C,3)>EMA13 AND (C>EMA55 OR ABS(1-C/EMA55)<0.01);
LZHT:=LZ1 AND LZ2 AND LZ3 AND LZ4;
DRAWTEXT(LZHT AND FILTER(LZHT,5),L-0.1,'浪子'),COLOR00FF99;
{走四方}
ZSF1:=REF(C,4)>REF(O,4) AND(REF(C,4)>EMA13 OR REF(C,4)>EMA34) AND (ABS(1-REF(EMA55,4)/EMA55)<0.01 OR MA(EMA55,4)>REF(EMA55,5));
ZSF2:=COUNT(ABS((1-REF(C,1)/C)*100)<3,4)=4 AND REF(V,4)*0.8>MA(V,4);
ZSF:=ZSF1 AND ZSF2;
DRAWTEXT(ZSF AND FILTER(ZSF,4),L-0.05,'走四方'),COLORLIBLUE;
{一枝獨秀}
YZ1:=C/O>1.01 AND H/C>1.025 ;{收陽有上影}
YZ2:=EMA13>MAX(EMA34,EMA55) AND C>1.05*EMA13 AND O>MA(C,11);{昨收陽 今大于均線}
YZDX:=YZ1 AND YZ2;
DRAWTEXT(YZDX,(H+C)/2,'獨秀'),COLOR00FF99;
{獨上高樓}
DSGL1:=REF(C,1)>=REF(O,1);
DSGL2:=O/REF(C,1)>1.029 AND O/C>1.03 AND O/MAX(EMA13,EMA55)>1.03;
DSGL:=DSGL1 AND DSGL2;
DRAWTEXT(DSGL,(O+C)/2,'高樓'),COLORRED;
{金屋藏嬌}
JWCJ1:=O>C AND REF(O,1)>REF(C,1);
JWCJ2:=O<=REF(C,1) AND L>=REF(L,1);
JWCJ3:=REF(C,1)/REF(L,1)>1.02;
JWCJ4:=EMA34>EMA13 OR EMA55>EMA13;
JWCJ:=JWCJ1 AND JWCJ2 AND JWCJ3 AND JWCJ4;
DRAWTEXT(JWCJ,LOW-0.2,'藏嬌'),COLORYELLOW;
{日月合璧}
RYHB1:=REF(O,1)<=REF(C,2) AND REF(O,1)>REF(C,1) AND ABS(1-REF(C,1)/REF(L,1))<0.02;
RYHB2:=C>O AND ABS(1-C/REF(O,1))<0.025 AND ABS(1-O/REF(C,1))<0.025;
RYHB3:=REF(EMA13,1)>EMA13 OR ABS(1-EMA13/REF(EMA13,1))<0.01 AND (EMA34>EMA13 OR EMA55>EMA13);
RYHB4:=REF(L,1)<=LLV(REF(L,1),10);
RYHB:=RYHB1 AND RYHB2 AND RYHB3 AND RYHB4;
DRAWTEXT(RYHB ,L+0.3,'日月'),COLORYELLOW;
{投石問路}
TSWL1:=CROSS(EMA13,EMA34) AND EMA55>EMA13;
DRAWTEXT(TSWL1,H+0.05,'投石'),COLOR0044FF;
{分道揚鑣}
FDYB:=CROSS(EMA34,EMA13) AND EMA34>EMA55;
DRAWTEXT(FDYB,L-0.1,'分道'),COLOR0044FF;
{三軍集結}
SJJJ3:=REF(EMA55,1)>REF(EMA13,1);
SJJJ4:=ABS(1-(MAX(MAX(EMA34,EMA55),EMA13)/MIN(MIN(EMA13,EMA34),EMA55)))<0.005;
SJJJ:=SJJJ3 AND SJJJ4;
DRAWTEXT(SJJJ AND FILTER(SJJJ,5),L-0.1,'三軍'),COLOR0044FF;
{突出重圍}
TCCW1:=REF(EMA13,1)>REF(EMA55,1);
TCCW2:=LLV(REF(EMA13,1),5)>EMA13 AND ABS(1-(MAX(MAX(EMA34,EMA55),EMA13)/MIN(MIN(EMA13,EMA34),EMA55)))<0.008;
TCCW:=TCCW1 AND TCCW2;
DRAWTEXT(TCCW AND FILTER(TCCW,5),H+0.01,'突圍'),COLOR00FF99;
{明修棧道}
MXZD1:=C/O>1.07;
MXZD2:=EMA13>HHV(REF(EMA13,1),5) AND V>HHV(REF(V,1),10) AND V/MA(REF(V,1),5)>2;
MXZD:=MXZD1 AND MXZD2;
DRAWTEXT(MXZD,H-0.25,'棧道'),COLOR00C5FF;
{暗度陳倉}
ADCC1:=O/C>1.05 AND EMA13/EMA55<1.1 AND EMA13>MA(EMA13,5);
ADCC2:=O/REF(C,1)<1.03;{HHV(REF(V,1),5)>V AND V/MA(REF(V,1),5)<2}
ADCC:=ADCC1 AND ADCC2;
DRAWTEXT(ADCC,(C+O)/2,'陳倉'),COLOR0099FF;
{破鏡重圓}
PJCY1:=REF(O,1)/REF(C,1)>1.02;
PJCY2:=O<=REF(C,1) AND C>=REF(O,1);
PJCY3:=(ABS(1-REF(C,1)/EMA55)<0.05 OR ABS(1-C/EMA55)<0.05 OR ABS(1-MA(C,2)/EMA55)<0.05);
PJCY4:=EMA13>EMA55 OR EMA13>MA(EMA13,5);
PJCY:=PJCY1 AND PJCY2 AND PJCY3 AND PJCY4;
DRAWTEXT(PJCY,LOW,'重圓'),COLORYELLOW;
{一石二鳥}
YSEN1:=REF(C,2)>REF(O,2) AND REF(O,1)>REF(C,1) AND O>C;
YSEN2:=REF(C,2)>EMA55 AND EMA13>EMA55 AND EMA13>=MA(EMA13,5);
YSEN3:=REF(V,2)>REF(V,1) AND REF(V,2)>V;
YSEN:=YSEN1 AND YSEN2 AND YSEN3;
DRAWTEXT(YSEN,H+0.01,'二鳥'),COLORLIBLUE;
{拖泥帶水}
TNDS1:=O/REF(C,1)>1.05 AND MIN(C,O)/L>1.03;
TNDS2:=C/MAX(EMA13,EMA55)>1.03 AND C>REF(C,1);
TNDS:=TNDS1 AND TNDS2;
DRAWTEXT(TNDS,(O+C)/2,'拖泥'),COLOR00FF99;
{金蟬脫殼}
JCTQ1:=O>C AND (EMA13/EMA55>1.1 OR (C/MIN(EMA13,EMA55)>1.1)) AND EMA13>MA(EMA13,5);
JCTQ2:=REF(O,1)>=REF(C,2) AND REF(C,1)>REF(O,1) AND O<=REF(C,1) AND C>REF(O,1);
JCTQ:=JCTQ1 AND JCTQ2;
DRAWTEXT(JCTQ,(O+C)/2,'脫殼'),COLORRED;
{一箭穿心}
YJCX:=CROSS(EMA55,EMA13);
DRAWTEXT(YJCX,H+0.1,'穿心'),COLOR0044FF;
{步步高}
BBG1:=C>=REF(C,1) AND REF(C,1)>=REF(C,2);{3日內收盤價都比前日收盤價高}
BBG2:=V>=REF(V,1) AND REF(V,1)>=REF(V,2);{3日內量都比前日量高}
BBG3:=COUNT(C>=O,3)=3;
BBG:=BBG1 AND BBG2 AND BBG3;
DRAWTEXT(BBG AND FILTER(BBG,3),(C+O)/2-0.1,'步高'),COLOR00FF99;
{雙飛燕}
SFY1:=EMA13>EMA34 AND EMA34>EMA55;
SFY2:=REF(O,1)>=REF(C,2) AND O>=REF(C,1) AND REF(C,2)>=REF(O,2);
SFY3:=COUNT(C>O AND C/O<1.02,2)=2 OR COUNT(O>C AND O/C<1.02,2)=2;
SFY4:=REF(V,1)>V;
SFY:=SFY1 AND SFY2 AND SFY3 AND SFY4;
DRAWTEXT(SFY AND FILTER(SFY,2),L,'雙飛燕'),COLORYELLOW;
{三劍客}
SJK1:=EMA13>EMA34 AND EMA34>EMA55;
SJK2:=COUNT(C<=O AND O/C<1.03,3)=3 AND COUNT(ABS(1-REF(C,1)/C)<1.03,2)=2;
SJK:=SJK1 AND SJK2;
DRAWTEXT(SJK AND FILTER(SJK,3),L,'三劍客'),COLORYELLOW;
{四星望月}
SXWY1:=COUNT(C>=O AND C/O<1.03,4)=4;
SXWY2:=(ABS(EMA13-EMA34)+ABS(EMA34-EMA55))/C<0.1;{主均線相距很近或基本持平}
SXWY3:=EMA55>EMA13;
SXWY:=SXWY1 AND SXWY2 AND SXWY3;
DRAWTEXT(SXWY AND FILTER(SXWY,5),H,'望月'),COLOR00C5FF;
{星星點燈}
XXDD1:=ABS(1-C/O)*100<=2.5 AND H/MAX(C,O)>1.03 AND REF(C,1)/REF(O,1)>1.05;
XXDD2:=O>=REF(C,1) AND ABS(1-REF(EMA13,1)/EMA55)<0.1;
XXDD:=XXDD1 AND XXDD2;
DRAWTEXT(XXDD,(O+C)/2,'點燈'),COLOR0099FF;
{過河拆橋}
GHCQ1:=O>C AND O/C>=1.04;
GHCQ2:=O>EMA13 AND EMA13>C;
GHCQ3:=EMA13/EMA55>1.1 AND ABS(1-EMA13/MA(EMA13,3))<0.02;
GHCQ:=GHCQ1 AND GHCQ2 AND GHCQ3;
DRAWTEXT(GHCQ,(O+C)/2,'拆橋'),COLOR0099FF;
{狗急跳墻}
GJTQ1:=O/REF(C,1)>1.02 AND L>REF(C,1);
GJTQ2:=V>MA(V,5);
GJTQ3:=EMA13/EMA55>1.1;
GJTQ:=GJTQ1 AND GJTQ2 AND GJTQ3;
DRAWTEXT(GJTQ,(O+C)/2-0.1,'跳墻'),COLOR0099FF;
{雙蹄并進}
STBJ1:=CROSS(DMI.PDI,DMI.MDI);
STBJ2:=ABS(1-DMI.ADX/DMI.ADXR)<0.1;
STBJ:=STBJ1 AND STBJ2;
DRAWTEXT(STBJ,(O+C)/2+0.1,'雙蹄并進'),COLORGREEN;
{一劍封喉}
YJFH1:=REF(C,1)>=REF(O,1);
YJFH2:=H/MAX(C,O)>=1.035 ;
YJFH3:=V/MA(REF(V,1),11)>3 AND EMA13/EMA55>1.05;
YJFH:=YJFH1 AND YJFH2 AND YJFH3;
DRAWTEXT(YJFH,(H+L)/2,'封喉'),COLORRED;
{小鳥依人}
XNYR1:=REF(C,1)/REF(O,1)>1.05;
XNYR2:=O<=REF(C,1) AND ABS(1-C/O)<0.02;
XNYR3:=COUNT(JGEQ OR YYSX OR HYXN,10)>=1 AND COUNT(JGEQ OR YYSX OR HYXN,2)=0;
XNYR:=XNYR1 AND XNYR2 AND XNYR3;
DRAWTEXT(XNYR,H-0.1,'鳥依人'),COLORLIBLUE;
{立竿見影}
LGJY1:=O<=REF(C,1) AND REF(V,1)>V AND O>C;
LGJY2:=COUNT(JGEQ OR YYSX OR HYXN,2)=1;
LGJY:=LGJY1 AND LGJY2;
DRAWTEXT(LGJY,H+0.1,'立竿'),COLORLIBLUE;
{節外生枝}
JWSZ1:=EMA13>MAX(EMA34,EMA55) AND EMA13/EMA55>1.1 AND REF(C,1)>1.04*EMA13 AND REF(C,1)/REF(O,1)>1.04;
JWSZ2:=ABS(1-C/O)<0.015 AND ABS(1-REF(C,1)/C)<0.02;
JWSZ:=JWSZ1 AND JWSZ2;
DRAWTEXT(JWSZ,(H+C)/2,'生枝'),COLOR00FF99;
{笑里藏刀}
XLCD1:=REF(H,1)/MAX(REF(C,1),REF(O,1))>1.04;
XLCD2:=REF(H,1)>H AND O>=REF(C,1);
XLCD3:=EMA13/EMA55>1.05 AND C/EMA13>1.03;
XLCD:=XLCD1 AND XLCD2 AND XLCD3;
DRAWTEXT(XLCD,(O+C)/2,'藏刀'),COLOR00FF99;
{馬失前蹄}
MSQT1:=EMA55/EMA13>1.04 AND EMA13/C>1.03;
MSQT2:=O<=REF(L,1) AND REF(O,1)/REF(C,1)>1.03;
MSQT:= MSQT1 AND MSQT2;
DRAWTEXT(MSQT,(O+C)/2,'失蹄'),COLORYELLOW;
{絕處逢生}
JCFS1:=EMA55>EMA13 AND EMA13>C;
JCFS2:=O<=REF(L,1) AND C/O>1.05;
JCFS:= JCFS1 AND JCFS2;
DRAWTEXT(JCFS,H,'逢生'),COLORYELLOW;
{一陰三線}
YYSX1:=EMA13>C AND O>EMA13;{一陰三線}
YYSX2:=EMA34>C AND O>EMA34;
YYSX3:=EMA55>C AND O>EMA55;
YYYSX:=YYSX1 AND YYSX2 AND YYSX3;
DRAWTEXT(YYYSX,H+0.25,'陰三'),COLOR00FF99;
{落井下石}
LJXS1:=REF(L,1)>O AND EMA13/EMA55>1.05 AND O>C;
DRAWTEXT(LJXS1,H+0.01,'下石'),COLOR00C5FF;
{晨鐘暮鼓}
CZMG1:=REF(C,1)/REF(O,1)>1.05 AND REF(V,1)/REF(V,2)>2 AND HSL>3;
CZMG2:=C>O AND VCZMG:=CZMG1 AND CZMG2;
DRAWTEXT(CZMG,H,'暮鼓'),COLORF00FF0;
白馬線:MA(C,13),COLORRED,LINETHICK1;
黑馬線:MA(C,34),COLORYELLOW,LINETHICK1;
烈馬線:MA(C,55),COLOR9933CC,LINETHICK1;
K1:=BACKSET(白馬線波幅變窄:IF(K1,白馬線,DRAWNULL),COLOR00CC33,LINETHICK1;
K2:=BACKSET(黑馬線均線粘合:IF(K2,黑馬線,DRAWNULL),COLORFFCC66,LINETHICK1;
K3:=BACKSET(烈馬線隨時變盤:IF(K3,烈馬線,DRAWNULL),COLORBLUE,LINETHICK1;
投石叉:DRAWICON(CROSS(白馬線,黑馬線),黑馬線,1);
紅客叉:DRAWICON(CROSS(白馬線,烈馬線),烈馬線,1);
互換叉:DRAWICON(CROSS(黑馬線,烈馬線),烈馬線,1);
分道叉:DRAWICON(CROSS(黑馬線,白馬線),黑馬線,2);
穿心叉:DRAWICON(CROSS(烈馬線,白馬線),烈馬線,2);
各為叉:DRAWICON(CROSS(烈馬線,黑馬線),烈馬線,2);

股票公式推薦
在線查股
個股查股導航:股票行情查詢 DDX在線查詢 超贏數據查詢 資金流向 千股千評 個股最新消息 大小非解禁 十大股東查詢 分紅配股查詢 業績預告查詢
中天能源 600856+3.26% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
石基信息 002153+3.19% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
豫能控股 001896+3.17% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
ST巖石 600696+3.17% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
柏堡龍 002776+3.16% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
華通熱力 002893+3.14% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
西藏礦業 000762+3.14% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
金鴻順 603922+3.13% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
寶光股份 600379+3.13% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
融捷股份 002192+3.13% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
商務合作:在線客服
愛查股網不推薦股票,不收會員,網站內的廣告不代表本股票網的觀點,由此引起的一切法律責任均與本站無關,股市有風險,投資需謹慎。粵ICP備17111814號-1
特別提示:本站不為所提供數據的錯誤、殘缺、延遲或因依靠此信息所采取的任何行為負責。本股票網提供的所有內容僅供參考,不構成投資建議,投資者據此操作,風險自擔。
手機版(手機訪問當前頁面) | 電腦端(適合電腦或大屏用戶)
小丑扑克1手走势图