愛查股網 www.islmmw.live 股票查詢最好股票網 個股數據查詢好股網 手機訪問本頁
| 保存本站網址 | 關閉站內廣告
愛查股網
股票查詢最好股票網 個股數據查詢好股網
您的位置:愛查股網 > 股票公式 > 大智慧公式
股票行情查詢:

大智慧定量結構指標公式

2019/4/17 20:35:51

DIF:100*(EMA(CLOSE,12)-EMA(CLOSE,26));
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背離:=(CL1MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背離:=(CL1MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=(直接底背離 OR 隔峰底背離);
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背離,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背離,1));
底背離消失:=(REF(直接底背離,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背離,1) AND DIFL1<=DIFL3);
STICKLINE(B OR BG,DIF,DEA,8,0),colorred;
DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.5),'鈍化'),coloryellow;
DRAWTEXT(FILTER(BG,10),(DIF*1.5),'結構形成'),colormagenta;
DRAWTEXT(FILTER(底背離消失,10),(DIF+MACD),'消失'),colorgreen;
STICKLINE(BG,0,(DIF+DEA),5,0), colorred;
金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接頂背離:=(CH1>CH2 ) AND (MDIFT20 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰頂背離:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT30 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=(直接頂背離 OR 隔峰頂背離);
TG:=((MDIFT2頂背離消失:=(REF(直接頂背離,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰頂背離,1) AND DIFH1>=DIFH3);
STICKLINE(TG,0,(DIF+DEA),5,0), colorgreen;
STICKLINE(T OR TG,DIF,DEA,8,0),colorgreen;
DRAWTEXT(FILTER(TG,20),(DIF*1.4),'結構形成'),colormagenta;
DRAWTEXT(FILTER(頂背離消失,20),(DIF+MACD),'消失'),colorgreen;

股票公式推薦
在線查股
個股查股導航:股票行情查詢 DDX在線查詢 超贏數據查詢 資金流向 千股千評 個股最新消息 大小非解禁 十大股東查詢 分紅配股查詢 業績預告查詢
金財互聯 002530+2.92% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
新澳股份 603889+2.89% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
龍宇燃油 603003+2.88% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
天通股份 600330+2.87% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
*ST巴士 002188+2.87% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
露天煤業 002128+2.86% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
特力A 000025+2.85% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
東音股份 002793+2.85% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
宏川智慧 002930+2.84% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
旋極信息 300324+2.83% 千股千評 DDX指標 超贏 資金流向 大小非 股東 分紅
商務合作:在線客服
愛查股網不推薦股票,不收會員,網站內的廣告不代表本股票網的觀點,由此引起的一切法律責任均與本站無關,股市有風險,投資需謹慎。粵ICP備17111814號-1
特別提示:本站不為所提供數據的錯誤、殘缺、延遲或因依靠此信息所采取的任何行為負責。本股票網提供的所有內容僅供參考,不構成投資建議,投資者據此操作,風險自擔。
手機版(手機訪問當前頁面) | 電腦端(適合電腦或大屏用戶)
小丑扑克1手走势图